• Announcements

    • Budfred

      IE 11 copy/paste problem

      It has come to our attention that people using Internet Explorer 11 (IE 11) are having trouble with copy/paste to the forum. If you encounter this problem, using a different browser like Firefox or Chrome seems to get around the problem. We do not know what the problem is, but it seems to be specific to IE 11 and we are hopeful that Microsoft will eventually fix it.
    • Budfred

      PLEASE READ - Reversing upgrade   02/23/2017

      We have found that this new upgrade is somewhat of a disaster.  We are finding lots of glitches in being able to post and administer the forum.  Additionally, there are new costs associated with the upgrade that we simply cannot afford.  As a result, we have decided to reverse course and go back to the previous version of our software.  Since this will involve restoring it from a backup, we will lose posts that have been added since January 30 or possibly even some before that.    If you started a topic during that time, we urge you to make backups of your posts and you will need to start the topics over again after the change.  You can simply paste the copies of your posts that you created at that point.    If you joined the forum this month, you will need to re-register since your membership will be lost along with the posts.  Since you have a concealed password, we cannot simply restore your membership for you.   We are going to backup as much as we can so that it will reduce inconvenience for our members.  Unfortunately we cannot back everything up since much will be incompatible with the old version of our software.  We apologize for the confusion and regret the need to do this even though it is not viable to continue with this version of the software.   We plan to begin the process tomorrow evening and, if it goes smoothly, we shouldn't be offline for very long.  However, since we have not done this before, we are not sure how smoothly it will go.  We ask your patience as we proceed.
Sign in to follow this  
Followers 0
jaran

Trojan Horse "BackDoor.Agent.BA"

5 posts in this topic

Hello and thank you all in advance who help fight against spyware.

 

I recently had some nasty spyware that Autodad helped me eradicate. (Thank you Autodad!) Now I am trying to help my brother clean up his laptop. I went through the HiJackThis do-it-yourself walkthrough but can't seem to get this one last Trojan Horse "BackDoor.Agent.BA".. I have tried to get rid of it with HiJackThis, AVG Anti-Virus, Ad-Aware and Spybot S&D.

 

Below is the most recent HiJackThis log... you'll notice at the bottom... 018 and 020... after trying to eliminate the trojan at 020, 018 appeared, which I couldn't fix either. Your assistance in this matter will be greatly appreciated as I do realize that the helpers here do this voluntarily. Thanks again.

 

Logfile of HijackThis v1.98.0

Scan saved at 9:04:12 AM, on 7/5/2004

Platform: Windows XP SP1 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

 

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\spoolsv.exe

C:\WINDOWS\System32\Ati2evxx.exe

C:\PROGRA~1\Grisoft\AVG6\avgserv.exe

C:\WINDOWS\Explorer.EXE

C:\WINDOWS\system32\slserv.exe

C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe

C:\documents and settings\jaran\local settings\temp\Gl.exe

C:\PROGRA~1\Grisoft\AVG6\avgcc32.exe

C:\Program Files\Hewlett-Packard\HP Software Update\HPWuSchd.exe

C:\Program Files\HP\hpcoretech\hpcmpmgr.exe

C:\Program Files\Hewlett-Packard\Digital Imaging\bin\hpotdd01.exe

C:\WINDOWS\System32\plxozi.exe

C:\WINDOWS\System32\wuauclt.exe

C:\PROGRA~1\Yahoo!\browser\ycommon.exe

C:\Program Files\Yahoo!\browser\ybrwicon.exe

C:\HJT\HijackThis.exe

 

O2 - BHO: (no name) - {3B8C3306-EF1C-05CC-D957-645504A77A45} - C:\WINDOWS\System32\yxy.dll

O2 - BHO: Band Class - {C5183ABC-EB6E-4E05-B8C9-500A16B6CF94} - C:\Program Files\SEP\sep.dll

O4 - HKLM\..\Run: [ATIModeChange] Ati2mdxx.exe

O4 - HKLM\..\Run: [ATIPTA] C:\Program Files\ATI Technologies\ATI Control Panel\atiptaxx.exe

O4 - HKLM\..\Run: [synTPLpr] C:\Program Files\Synaptics\SynTP\SynTPLpr.exe

O4 - HKLM\..\Run: [synTPEnh] C:\Program Files\Synaptics\SynTP\SynTPEnh.exe

O4 - HKLM\..\Run: [EM_EXEC] C:\PROGRA~1\Logitech\MOUSEW~1\SYSTEM\EM_EXEC.EXE

O4 - HKLM\..\Run: [Gl] C:\documents and settings\paul bonaldi\local settings\temp\Gl.exe

O4 - HKLM\..\Run: [4398WHP3XGXEDZ] C:\WINDOWS\System32\Reyd4kLS.exe

O4 - HKLM\..\Run: [Dsi] C:\WINDOWS\System32\dp-him.exe

O4 - HKLM\..\Run: [emsw.exe] C:\WINDOWS\emsw.exe

O4 - HKLM\..\Run: [AVG_CC] C:\PROGRA~1\Grisoft\AVG6\avgcc32.exe /STARTUP

O4 - HKLM\..\Run: [HP Software Update] "C:\Program Files\Hewlett-Packard\HP Software Update\HPWuSchd.exe"

O4 - HKLM\..\Run: [HP Component Manager] "C:\Program Files\HP\hpcoretech\hpcmpmgr.exe"

O4 - HKLM\..\Run: [DeviceDiscovery] C:\Program Files\Hewlett-Packard\Digital Imaging\bin\hpotdd01.exe

O4 - HKCU\..\Run: [Yahoo! Pager] 1

O4 - HKCU\..\Run: [Flapsfjf] C:\WINDOWS\System32\plxozi.exe

O8 - Extra context menu item: Yahoo! Dictionary - file:///C:\Program Files\Yahoo!\Common/ycdict.htm

O8 - Extra context menu item: Yahoo! Search - file:///C:\Program Files\Yahoo!\Common/ycsrch.htm

O9 - Extra button: (no name) - {120E090D-9136-4b78-8258-F0B44B4BD2AC} - C:\WINDOWS\System32\ms.exe (file missing)

O9 - Extra 'Tools' menuitem: MaxSpeed - {120E090D-9136-4b78-8258-F0B44B4BD2AC} - C:\WINDOWS\System32\ms.exe (file missing)

O9 - Extra button: Yahoo! Login - {2499216C-4BA5-11D5-BD9C-000103C116D5} - C:\Program Files\Yahoo!\Common\ylogin.dll

O9 - Extra 'Tools' menuitem: Yahoo! Login - {2499216C-4BA5-11D5-BD9C-000103C116D5} - C:\Program Files\Yahoo!\Common\ylogin.dll

O9 - Extra button: Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - C:\Program Files\Yahoo!\Messenger\yhexbmes.dll

O9 - Extra 'Tools' menuitem: Yahoo! Messenger - {4528BBE0-4E08-11D5-AD55-00010333D0AD} - C:\Program Files\Yahoo!\Messenger\yhexbmes.dll

O9 - Extra button: Real.com - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - C:\WINDOWS\System32\Shdocvw.dll

O16 - DPF: {30528230-99f7-4bb4-88d8-fa1d4f56a2ab} - C:\Program Files\Yahoo!\common\yinsthelper.dll

O16 - DPF: {D18F962A-3722-4B59-B08D-28BB9EB2281E} (PhotosCtrl Class) - http://photos.yahoo.com/ocx/us/yexplorer1_9us.cab

O18 - Protocol: cetihpz - {CF184AD3-CDCB-4168-A3F7-8E447D129300} - C:\Program Files\HP\hpcoretech\comp\hpuiprot.dll

O20 - AppInit_DLLs: C:\WINDOWS\System32\wdmopae.dll

 

Jaran

aka.. Shlock

 

ps.. although I already have my own account (Shlock), I created this account (Jaran) for my brother just in case he needs some assistance later.

Share this post


Link to post
Share on other sites

Trojanhorse.Backdoor.Agent.BA

 

I have now removed the virus and this is how.............

 

You have to turn off the system restore as mentioned previously. If you can not find the virus in the System32 folder, do a search for the path in the registry. In my case the file was windows/system32/comami.dll. You can delete the file here but as in my case the file was rewritten, even when deleted in safe mode. To stop this I was told in another forum to rename HKLM/software/microsoft/windowsnt/currentversion/windows/ and rename the path to

 

HKLM/software/microsoft/windowsnt/currentversion/windows2

 

rename and then delete the file.

The virus can not rewrite it self if you remae the for-mentioned path.

 

I reran Avg and was once again was informed that the virus was still there.

I searched the reg and the comami.dll was no longer found. I then went into system32 and did a search and found the file (make certain that the view all hidden files and folders is enabled) but of course access was denied. After rebooting in safe mode I then copied the file to the recycle bin and and deleted it. After like 30 AVG scans, its now clean...

 

I have been working on this problem for over a week, and have searched all over the net ...

 

I have been told to use hijack, remove the file in safemode but the file could not be found.

I tried the AVG new tool backdooragent remover and it failed.

I downloaded new updates as I was working on this for several days and rerunning AVG did nothing same deal.. 1 virus found...

 

Email my@elizabethboro.com if anyone needs help..........

Share this post


Link to post
Share on other sites

This approach worked for me as well...I had a dll file in my c:\windows\system32 directory. To dlete the file I used Trojan Remover after I had changed Reg entry as per above. Then deleted all references to the virus in the registry....Thank you !

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0