Jump to content


Photo

Updating Firefox with the 'Shell:' patch


  • Please log in to reply
4 replies to this topic

#1 mellonhead

mellonhead

    Member

  • Full Member
  • Pip
  • 32 posts

Posted 14 July 2004 - 10:20 AM

I am trying to update the .9 Version of Firefox with the 'Shell:' patch, from the Mozilla website. It says to click on the "update' button, then select 'install'. When I click on it I just get a new tab that says 'Untitled' that's blank. The link is not connecting properly. I have a Kerio firewall with firefox.exe granted TCP outbound access, and nothing seems to be blocked in the log.

Anyone have an idea? Not a big deal, 'cause I can simply install the .92 version over my existing install.... but just curious.

#2 Stilcho

Stilcho

    Member

  • Full Member
  • Pip
  • 5 posts

Posted 14 July 2004 - 04:32 PM

when I updated mine (0.9.1), I just went to the offical main page and used thier security update link. everything went well, also there is a instruction there if it's installed right. might want to check that. I didn't used the update features in FF. so far so good.

#3 Mike

Mike

    Dark Lord of SWI

  • Emeritus
  • PipPipPipPipPip
  • 514 posts

Posted 14 July 2004 - 05:29 PM

Odd. Have you disabled the XPI installer somehow? It should trigger the XPI installer dialog.
SpywareInfo: How are you gentlemen?? All your base are belong to us!!
Spyware: What you say!!
SpywareInfo: You have no chance to survive. Make your time!

#4 Acsell

Acsell

    Advanced Member

  • Developer
  • PipPipPip
  • 160 posts

Posted 14 July 2004 - 07:18 PM

You could try this-

Tools -> Options -> Advanced -> Software Update -> Allow websites to install software

edit:

Another thing you could try-

save the *.xpi file to your desktop (right click on the link>save link as)

right click on the *.xpi file and select "open with" double click "firefox" (or, if it isn't listed go to "choose program" and double click firefox from the long list)

Edited by Acsell, 14 July 2004 - 07:49 PM.

ASAP - Alliance of Security Analysis Professionals - Proud Member Since 2004
HJTHotkey - HijackThis Tutorial (Unofficial) - GetFiles
Autohotkey - Automation. Hotkeys and Scripting - Mozilla Firefox

#5 mellonhead

mellonhead

    Member

  • Full Member
  • Pip
  • 32 posts

Posted 15 July 2004 - 09:22 AM

Ahh.... I did disable the "allow websites to install software" option (sounded rather like a dangerous Microsoft option to me). So I'll give it a try.

The download-and-'open with Firefox' thing I tried, unsuccessfully.

Thank-you for the tips!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Member of ASAP and UNITE
Support SpywareInfo Forum - click the button