• Announcements

    • Budfred

      IE 11 copy/paste problem

      It has come to our attention that people using Internet Explorer 11 (IE 11) are having trouble with copy/paste to the forum. If you encounter this problem, using a different browser like Firefox or Chrome seems to get around the problem. We do not know what the problem is, but it seems to be specific to IE 11 and we are hopeful that Microsoft will eventually fix it.
    • Budfred

      PLEASE READ - Reversing upgrade   02/23/2017

      We have found that this new upgrade is somewhat of a disaster.  We are finding lots of glitches in being able to post and administer the forum.  Additionally, there are new costs associated with the upgrade that we simply cannot afford.  As a result, we have decided to reverse course and go back to the previous version of our software.  Since this will involve restoring it from a backup, we will lose posts that have been added since January 30 or possibly even some before that.    If you started a topic during that time, we urge you to make backups of your posts and you will need to start the topics over again after the change.  You can simply paste the copies of your posts that you created at that point.    If you joined the forum this month, you will need to re-register since your membership will be lost along with the posts.  Since you have a concealed password, we cannot simply restore your membership for you.   We are going to backup as much as we can so that it will reduce inconvenience for our members.  Unfortunately we cannot back everything up since much will be incompatible with the old version of our software.  We apologize for the confusion and regret the need to do this even though it is not viable to continue with this version of the software.   We plan to begin the process tomorrow evening and, if it goes smoothly, we shouldn't be offline for very long.  However, since we have not done this before, we are not sure how smoothly it will go.  We ask your patience as we proceed.   EDIT: I have asked our hosting service to do the restore at 9 PM Central time and it looks like it will go forward at that time.  Please prepare whatever you need to prepare so that we can restore your topics when the forum is stable again.
Sign in to follow this  
Followers 0
Distillers

Can't view source.

11 posts in this topic

If you're in Firefox, you can hit Ctrl+U and see the source.

 

IE has no shortcuts for source viewing outside the menu.

Share this post


Link to post
Share on other sites

In IE, View (in the menu bar) -> Source

Shortcut would be Alt-V,c

Share this post


Link to post
Share on other sites

What OS (which Windows)? And what version of IE?

Share this post


Link to post
Share on other sites

Platform: Windows XP SP1 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

 

But do you mean

 

Hold Alt, press V, don't hold Alt and tapping c?

or

Hold Alt, press V and C?

 

:unsure:

Edited by H@ns

Share this post


Link to post
Share on other sites

Hold Alt, press V, don't hold Alt and tapping c. Works for me - same OS and IE.

Share this post


Link to post
Share on other sites

Strange. Maybe you have the English IE, and I the Dutch. But it doesn't work here :techsupport:

Share this post


Link to post
Share on other sites

I neglected to mention that you can right-click the page and hit View Source in the menu that pops up.

 

It's the most obvious things, really...

Share this post


Link to post
Share on other sites
I neglected to mention that you can right-click the page and hit View Source in the menu that pops up.

 

It's the most obvious things, really...

65661[/snapback]

 

:)

 

 

Synopsis:

When using Internet Explorer, cannot view the source of a web page? Try deleting the Temporary Internet Files.

 

Quick Solutions:

Compendium - Quick list of view source solutions

View Source Problem:

Normally the source can be viewed by using the Source command in the View menu, which opens it in Notepad. And also by using the Source command in the popup menu (in Windows, by right-clicking on the page - but not on an image or other object.) In addition to View Source not working, the Edit button is not enabled. This is located on the Standard Buttons toolbar. Normally it would open the page in an external program, such as Notepad.

 

Solution:

Delete the Temporary Internet Files, otherwise known as the disk cache. The cache includes local copies of web pages and files, so the browser doesn't have to download them again.

 

In the Tools menu, open Internet Options.... In the General tab, in the Temporary Internet files section, click on Delete Files.

 

It seems "view source" is affected when the cache gets too large in size. Internet Explorer takes the source from the Temporary Internet Files folder to the folder specified by the TMP environment variable. Refer to Microsoft article Q179829 for more information about this.

 

Feedback Solutions:

Here are some suggestions based on feedback I've gotten. All entries are in my words, unless otherwise noted. Added is when the entry was included in this page, Updated is when I last modified the entry, From is the name of the person who wrote with the suggestion, Version is the version of Windows and IE if a specific combination is known, and Synopsis is an overview.

 

I've gotten a couple feedback messages from people who've tried the advanced solutions first, and it was the simple solutions that helped them. Because of this, the order is no longer chronological. The simple solutions are now listed first. Refer to the Difficulty, which is marked as Easy or Advanced based on relative simplicity. You may want to try the simple solutions first. Each feedback also has a Category describing if it's a solution or something else like a prevention tip.

 

(1) Notepad on desktop

Category: Solution | Difficulty: Easy

From: JR / Dave * | Added: September 01, 2003 | Updated: March 22, 2004 | Version: Windows - any / IE - any

 

If there is a shortcut to Notepad on the desktop, delete or rename it to something other than Notepad.

 

JR wrote how to reproduce the problem, then solve it:

 

Open IE, go to any page, view source, works fine.

Now go to Start menu and navigate to "Programs\Accessories", and right-click

on Notepad, drag it to the desktop, selecting "Copy Here" when you let go.

You should now have a shortcut file named "Notepad" on your desktop.

Go back to IE, view source, and nothing happens.

Go back to desktop and delete or rename the Notepad shortcut.

Go back to IE, view source, and it works again.

 

 

* JR and Dave wrote two independent mredkj feedbacks about this solution. Yet I have not been able to reproduce it myself in the following combinations: NT/IE 5.5, Win2000/IE 5, and XP/IE 6. There must be other factors that cause a desktop shortcut to affect view source, such as Windows/IE patch versions and registry settings.

 

Usenet post - This is the earliest reference (2002-12-20 23:46:48 PST) I could find to the Notepad on the desktop solution (via Google Groups archive).

 

One variation of this issue I can reproduce is when I have a batch file on my desktop named notepad.bat. Trying to view source in IE will run that batch file, and obviously I can't view source. This is not a good thing, since it could be a security vulnerability if a malicious program was executed in the batch file. I was reluctant to mention this, in case it would give hackers/crackers ideas, but I'm sure they already know. As a precaution, don't download suspicious files to your computer, especially files named Notepad to your desktop.

 

(2) Notepad in Quick Launch toolbar

Category: Solution | Difficulty: Easy

From: Alex | Added: September 08, 2004 | Updated: September 08, 2004 | Version: Windows - any / IE - any

 

If there's a shortcut to Notepad in your Quick Launch toolbar, rename it to something other than Notepad.

 

Instructions to rename a shortcut in the Quick Launch.

 

Alex said:

 

I had an issue where I could view the source of some pages but not others. I had a "Notepad" shortcut in my XP taskbar, and when I renamed this to "Text viewer" (as recommended for shortcuts on the desktop) View Source worked fine again for all pages.

(3) Even after deleting the Temporary Internet Files, hidden files may still remain

Category: Solution | Difficulty: Easy

From: Sheila | Added: August 23, 2004 | Updated: August 23, 2004 | Version: Windows - any / IE 5 or 6

 

According the Microsoft Knowledge Base article 301057, Temporary Internet Files may use more space than specified. This may be caused by incomplete downloads or for other reasons. Even after deleting the files (Tools > Internet Options... > Delete Files...) they will remain and are not visible in Windows Explorer. Although not mentioned in the article, if the remaining file or files take up too much space, it could cause the same view source problem mentioned in the main solution above.

 

Thanks to Sheila who discovered Microsoft's KB article, and explained how following their workaround helped restore View Source. The workaround is to relocate the Temporary Internet Files folder. For the exact steps, refer to Microsoft's article 301057.

 

Here is essentially what Sheila did. Warning: The original Temporary Internet Files folder will be deleted.

 

Let's say your Temporary Internet Files is set to

C:\Documents and Settings\YourUser\Local Settings\Temporary Internet Files

In Windows Explorer, create a new folder Temporary Internet Files 2

In Internet Explorer, go to the Tools menu, then Internet Options.... In the General tab, in the Temporary Internet files section, click Settings.... In the Settings dialog, in the Temporary Internet files folder section, click Move Folder... Find the folder Temporary Internet Files 2 and click OK.

Reboot

View Source should work (if this was the problem)

 

An additional note from Sheila:

 

Another symptom of this problem also seems to be that when you copy images 'save picture as' .. they all save as .bmp ... this was also resolved and I can now save .jpg and .gif

(4) Set the HTML editor to Notepad instead of Microsoft FrontPage

Category: Solution | Difficulty: Easy

From: Lars | Added: June 21, 2003 | Updated: September 01, 2003 | Version: Windows - any / IE - any

 

While in Internet Explorer, go to the Tools menu, then Internet Options. In the Programs tab, change the HTML editor drop down to Notepad. You can also get to Internet Options from the Control Panel.

 

Lars wrote:

 

[if] your default HTML editor is referring to any software that is not installed on your computer you will also end up with the "can't View Source in IE" problem.

 

(5) Uncheck Auto-Select for Encoding

Category: Solution | Difficulty: Easy

From: Ralph | Added: January 20, 2004 | Updated: January 20, 2004 | Version: Windows 2000 (maybe any) / IE 6

 

Internet Explorer can be set to automatically detect the charset encoding, but this may cause View Source to stop working for certain pages. A workaround is to turn off Auto-Select.

 

Ralph wrote:

 

This occurred on Win2k Pro SP3 and IE 6 SP1. You are correct that Auto-Select can be set independently of an encoding. The issue occurs if Auto-Select is selected, irregardless of the selected encoding. The problem is consistently reproducible when checking the Auto-Select feature. It does occur on specific web pages that are English, some of which are internal and definitely all English. It occurs consistently on these web pages. It's probably about 40% of web pages that it occurs on though. The issue did not start until after a Windows Update though, so I'm fairly confident that it was an update that triggered the issue. Which update I could not say though.

 

While in Internet Explorer, go to the View menu, then Encoding and uncheck Auto-Select.

 

Usenet post - Here is one reference I found to the problem (2003-01-28 08:01:09 PST).

 

(6) Prevent cache from getting too large

Category: Prevention | Difficulty: Easy

From: "ThanksAlot" | Added: June 01, 2001 | Updated: September 01, 2003 | Version: Windows - any / IE - any

 

Prevent the problem by adjusting the amount of disk space the cache uses. To change the amount of disk space, go to the Tools menu and open Internet Options.... In the General tab's Temporary Internet files section, open Settings.... Here you can use the slider or change the amount of disk space by typing into the text box. "ThanksAlot" set the cache to use up to 50 MB of disk space.

(7) Set browser to clear cache on close

Category: Prevention | Difficulty: Easy

From: Dan | Added: June 01, 2001 | Updated: September 01, 2003 | Version: Windows - any / IE - any

 

Prevent the problem by clearing the cache when the browser is closed. To activate this setting, go to the Tools menu and open Internet Options.... In the Advanced tab, go to the Security section. Check on or off the option to "Empty Temporary Internet Files folder when browser is closed".

(8) Missing registry setting

Category: Solution | Difficulty: Advanced

From: Dean | Added: August 02, 2002 | Updated: September 01, 2003 | Version: Windows - any / IE 6 upgrade

 

Warning: I have not tested this solution, so please use standard precautions when editing the Windows Registry. For more information about the registry, refer to WinGuides.com

 

The source of Dean's suggestion is Microsoft's Online Assisted Support, where one of the MS support technicians diagnosed the problem by asking questions in a series of emails. Unfortunately, this information was still not available in Microsoft's Knowledge Base last time I checked.

Microsoft's Online Assisted Support and Knowledge Base are available at support.microsoft.com.

 

Dean wrote:

 

1. Close any instances of IE.

 

2. Create this registry key if it does not already exist (chances are it does not exist):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name]

 

3. Modify the Default value of the "Editor Name" to the path of the program you want to use to view source code. For example, "C:\Program Files\Accessories\wordpad.exe" or "C:\Windows\notepad.exe"

 

Note: If the path contains blank spaces, please do not forget to add the quotation marks. Then when you click View>Source in Internet Explorer, the program you specified will open.

 

(9) Create another user account in Windows

Category: Solution | Difficulty: Advanced

From: Jim | Added: September 22, 2002 | Updated: September 01, 2003 | Version: Windows XP / IE 6

 

This is another one that I haven't tested. Caveat emptor.

 

Jim wrote:

 

Setup another user account with admin privileges and then copy over the desktop and favorites folders. That should work, but if it doesn't delete the new user account and most likely your original account will now work.

 

(10) Additional documentation for useful registry settings

Category: Supplemental | Difficulty: Advanced

From: Chris | Added: September 22, 2002 | Updated: September 01, 2003 | Version: Windows - any / IE - any

 

Chris wrote with a link to an MSDN page that would be helpful to those who need to change registry settings for View Source, HTML editors, etc.

 

Internet Explorer Client Registry Layout

 

 

 

Microsoft Knowledge Base Solutions:

After my View Source stopped working, I installed the Internet Explorer 5.01 Service Pack. That did not work. So, I looked at Microsoft's Knowledge Base to find some help. Here are some similar problems/solutions. For each link, I summarized their solution.

 

Update (November 09, 2002)

It was January 13, 2001 when I first put up this page, and Microsoft's Knowledge Base didn't have a "Delete Temporary Internet files" solution at the time. Either that or I couldn't find it, because I found an article now. Refer to Q306907 below. The article says it was last reviewed on Monday, October 07, 2002, but not when it was created.

 

Q154168 Cannot View Source in Internet Explorer.

Solution: Notepad needs to be installed.

Q179829 Cannot View HTML Source Code for Web Pages in Internet Explorer

Solution: Specify a valid path for the TMP environment variable.

Q203592 Cannot View Source Code for Web Pages

Solution: Include the Change permission for the Cookies folder.

Q306907 Source Code Is Not Displayed When You Click Source on the View Menu in Internet Explorer

Solution: Delete Temporary Internet files

Conclusion

To help prevent the problem, one should set the cache to use a small amount of disk space relative to the size of the hard disk. For the other cache settings, it is up to the individual. If clearing the cache every time the browser is closed seems drastic, then one could manually clear it occasionally. The following links offer a couple perspectives.

 

"Working Efficiently" (Microsoft) - The advice from Microsoft is to increase the cache size to improve efficiency.

 

"Keep it Clean" (Commerce Developers) - While Microsoft says to increase cache size, Commerce Developers suggests not letting Temporary Internet files get too large or outdated. We agree with this, because although pages will load faster when cached, there is a limit at which the cache will become inefficient.

 

Operating System and Browser

FYI: I am using Windows 2000 for my OS and Internet Explorer 5.0 for my browser.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0