• Announcements

    • Budfred

      IE 11 copy/paste problem

      It has come to our attention that people using Internet Explorer 11 (IE 11) are having trouble with copy/paste to the forum. If you encounter this problem, using a different browser like Firefox or Chrome seems to get around the problem. We do not know what the problem is, but it seems to be specific to IE 11 and we are hopeful that Microsoft will eventually fix it.
Sign in to follow this  
Followers 0
shellsworld

Excite won't load

10 posts in this topic

Since I've tightened all the security on my PC a while ago I haven't been able to load www.excite.com. Today I decided to try to rectify that, but I'm still at a loss.

 

I noticed that it uses imgfarm so I removed that from my restricted sites to see if that would help. Then I disabled all protection from Spyware Blaster to see if THAT would help. But as of this point I still can't access that site. I used to have a couple email accounts through excite but I probably don't anymore since I haven't been able to access it in quite a while.

 

Any help would be appreciated!

Share this post


Link to post
Share on other sites

Well..I can get there ok...have you looked in your Hosts File..?

or maybe PG has blocked the site in it's Lists...

Share this post


Link to post
Share on other sites

It's not in my hosts file. I'm afraid I don't know what you mean by PG. I can't access excite through any of my 3 browsers ... IE, Netscape and Firefox. So it must be something globally locked instead of browser dependent.

Share this post


Link to post
Share on other sites

Sorry...PG = PeerGuardian

You would be surprised how many users run this all the time instead of only when downloading.

Share this post


Link to post
Share on other sites

I'm not using Peer Guardian so that isn't it either. I use Kerio but I can't see anyplace that shows it's blocking Excite. I also have Spyware Blaster running but I've checked and I don't see excite in the list of restricted sites from there either. And I did disable that once and still couldn't get excite to load. I've even uninstalled IESPYADS in case that is doing it, but I still can't access it. I've cleared my cache and rebooted the PC so nothing should be running in the background either once I've shut them down or uninstalled them. I'm really at a loss here where to look anymore ... I guess it's not a big deal to go without Excite since I don't do much with it anymore but I just hate not having the ability to go if I want to ... :)

Share this post


Link to post
Share on other sites

Well, I was able to access and reactivate my excite email addresses by typing in mail.excite.com. That loaded. But the main excite page still will not load. It comes up with errors on the page no matter which browser I try. I guess, since I have my email addresses back I will be satisfied. Thanks for trying Lion. I'll just give up on the main page. :rolleyes:

 

Shellsworld

Share this post


Link to post
Share on other sites

OK I lied! :blush2: I didn't give up. I did find out as soon as I turned off my Kerio firewall I could access Excite without any problems at all. But I can't find a rule in the ruleset that says anything about Excite. Any ideas? As soon as I start up the firewall again I can't access excite pages, including help.excite.com or their chat page either.

 

shellsworld

Share this post


Link to post
Share on other sites

It might not say Excite..but in another Range...you need to find that IP & remove it....

Edited by lion7718

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0