• Announcements

    • Budfred

      IE 11 copy/paste problem

      It has come to our attention that people using Internet Explorer 11 (IE 11) are having trouble with copy/paste to the forum. If you encounter this problem, using a different browser like Firefox or Chrome seems to get around the problem. We do not know what the problem is, but it seems to be specific to IE 11 and we are hopeful that Microsoft will eventually fix it.
    • Budfred

      PLEASE READ - Reversing upgrade   02/23/2017

      We have found that this new upgrade is somewhat of a disaster.  We are finding lots of glitches in being able to post and administer the forum.  Additionally, there are new costs associated with the upgrade that we simply cannot afford.  As a result, we have decided to reverse course and go back to the previous version of our software.  Since this will involve restoring it from a backup, we will lose posts that have been added since January 30 or possibly even some before that.    If you started a topic during that time, we urge you to make backups of your posts and you will need to start the topics over again after the change.  You can simply paste the copies of your posts that you created at that point.    If you joined the forum this month, you will need to re-register since your membership will be lost along with the posts.  Since you have a concealed password, we cannot simply restore your membership for you.   We are going to backup as much as we can so that it will reduce inconvenience for our members.  Unfortunately we cannot back everything up since much will be incompatible with the old version of our software.  We apologize for the confusion and regret the need to do this even though it is not viable to continue with this version of the software.   We plan to begin the process tomorrow evening and, if it goes smoothly, we shouldn't be offline for very long.  However, since we have not done this before, we are not sure how smoothly it will go.  We ask your patience as we proceed.   EDIT: I have asked our hosting service to do the restore at 9 PM Central time and it looks like it will go forward at that time.  Please prepare whatever you need to prepare so that we can restore your topics when the forum is stable again.
Sign in to follow this  
Followers 0
Ciaran

Teknum Systems Updater

2 posts in this topic

Hi,

 

I was having a hard time trying to work out why the Teknum Systems updater program kept re-appearing in the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run registry key, even when it was deleted. At seemingly random intervals, TeaTimer (part of the SpyBot S&D suite) would pop up and tell me it had detected that this entry had re-appeared yet again. I couldn't work it out. I denied the change each time (explicitly not telling it to remember the decision because I wanted to track it down).

 

This isn't my computer, and the program that was causing it - EasyCrypto from Teknum Systems - had already been installed by someone else. I had removed it and removed its folder, since I knew it wasn't good, but it wasn't until I installed TeaTimer that I found out it was still trying to reappear. It didn't appear in HijackThis and SpyBot couldn't help.

 

Eventually, I cottoned on to the fact that it only tried to add itself to the Run key when I copied a file with Ctrl-C or right-clicked on a file. This made me even more confused, since I couldn't understand what sort of thing would trigger when I copied a file. Even worse, it was still happening in Safe Mode - obviously TeaTimer wasn't running but I could see with regedit that the entry was still appearing.

 

Eventually, I noticed that when I right-clicked on a file I would have in the context menu an option to "Add to EasyCrypto ZIP". Searching for this in regedit, I found this key:

 

HKEY_CLASSES_ROOT\CLSID\{A0752120-6D75-D111-B5B1-0800095A2318}

 

Examining it, it turned out to be a shell extension installed by EasyCrypto. The DLL file it referenced - C:\WINDOWS\system32\tsseCryp.dll - was checking to make sure the Updater was still in the Run key and adding it if not. Deleting the registry key solved the problem as it ensured the DLL wasn't called any more. The DLL was still in use so I couldn't delete it but I'm sure I'll be able to next time I reboot.

 

I hope this helps anybody who's tearing their hair out like I was, and I would like to humbly suggest that Explorer shell extensions are also listed in HijackThis as I can imagine some nasty things being done without the user's knowledge in there.

 

- Ciaran.

Edited by Ciaran

Share this post


Link to post
Share on other sites

Thanks so much. I installed their Shredder because I was trying to recover a HUGE directory that had been accidentally deleted and wanted to shred the files that were recovered, determined to be unwanted and removed again so that I didn't have to deal with them more than once.

 

Well, WinPatrol, which I had recommended and installed as a matter of course for GP kept popping up "added to you startup" messages. I set the file up to be deleted on reboot and rebooted when I got tired of its insistent attempts. I was alarmed when the same thing kept happening. :eek: I certainly didn't want to have made things worse than I found them or have to explain why I was spending so much time correcting a problem that I created. :zipped: Your post took me right to the registry key in question and I'm pretty the problem will go away and let me keep Shredder on the system, at least long enough to do what I wanted.

 

Thanks.

 

 

Edit: OK, my mistake. That removed the context menu. So I uninstalled it. I should have just grabbed AnalogX's Supershredder in the first place. What the heck, you try new things and they don't always work out.

Edited by jd004

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0