Jump to content


Photo

Cannot delete file: Cannot read from the source file or disk ... FOLDER FROM HELL!!!!


  • This topic is locked This topic is locked
8 replies to this topic

#1 piercehan

piercehan

    Member

  • Full Member
  • Pip
  • 3 posts

Posted 26 April 2006 - 05:32 PM

Ok i am on a MacBook Pro with microsoft XP Pro. i downloaded a folder from DC++ and now it wont go away.

Basically no matter what I try all i get is "Cannot delete file: Cannot read from the source file or disk."

SOOOOOOOOOO I went into safe mode (restarting and pressing F8) still did not work. Then i went into DOS and typed "del C:\OSX-XP Files\Trash\The Sound Of Animals Fighting - Lover, The Lord Has Left Us..(Advance) - 2006\The Sound of Animals Fighting - Lover, The Lord Has Left Us.." I get the message back that says
"The system cannot find the path specified."

soooo now what? I am not a genius in computers but im not an idiot and no matter what i do it just wont go away. i tried the "moveonboot" app and that did nothing ... i asked around my campus and everyone gives me advice but nothing works. this is not the typical file where you can just go to "ctrl+alt+delete" close anything weird that might be using it and then delete it. i tried turning off explorer.exe ... this is just getting ridiculous ... please help me!!!!!!!!

#2 spike_hacker_inc

spike_hacker_inc

    Member

  • Full Member
  • Pip
  • 7 posts

Posted 29 April 2006 - 07:41 AM

Hey there piercehan, welcome to SWI Support Forums.

Edit: Sorry, I am not allowed to post here until my training has been completed, another advanced user will attend to your post ASAP.

Cool

Edited by spike_hacker_inc, 29 April 2006 - 09:18 AM.


#3 thisisu2

thisisu2

    Member

  • Full Member
  • Pip
  • 5 posts

Posted 01 May 2006 - 08:23 AM

Try this file called "Unlocker" - http://majorgeeks.co...ad.php?det=4660
If that doesn't work, give "Pocket Kill Box" a shot: http://majorgeeks.co...ad.php?det=4709

#4 piercehan

piercehan

    Member

  • Full Member
  • Pip
  • 3 posts

Posted 01 May 2006 - 12:34 PM

Try this file called "Unlocker" - http://majorgeeks.co...ad.php?det=4660
If that doesn't work, give "Pocket Kill Box" a shot: http://majorgeeks.co...ad.php?det=4709



both do nothing ... anyone else?

#5 bamajim

bamajim

    Member

  • Security Colleague
  • Pip
  • 92 posts

Posted 04 May 2006 - 09:43 PM

piercehan

Locate the folder in Documents and settings->> Rt Click->>Properties.
In the bottom is the read only box have a green radio button or check?

If so Uncheck the read only box->> Apply->> Ok

Then see if you can delete it

bamajim
IPB Image

#6 piercehan

piercehan

    Member

  • Full Member
  • Pip
  • 3 posts

Posted 09 May 2006 - 11:51 PM

can someone please help me ... nothing has worked thus far!!!

#7 ScarBoro55

ScarBoro55

    Member

  • Full Member
  • Pip
  • 2 posts

Posted 11 May 2006 - 11:58 AM

can someone please help me ... nothing has worked thus far!!!


I just went through your agony, and I finally solved my undeletable folder like this.
  • Go to Start_Run and type CMD in the box. Enter.
  • Change directories to get to the parent folder of the renegade directory. (See the end of this msg for commands.)
  • Display the contents of the directory with DOS 8.3 naming convention (short names).
  • Find your bad directory and rename it to less than 8 letters. It is critical that you type the short file name when renaming. i.e., the Windows name is mybadfolder, but the 8.3 name will look like mybadf~1 or mybadf~2 ... use the short one. Rename it to anything you want as long as it is less than 8 letters.
  • Close the Command Line Editor.
  • Open Explorer and try to delete the folder you just renamed. Worked for me.
To Change Directories: Type cd.. to move up one level. Type cd yourfolder to move down one level within the directory you are currently in. Type cd\yourfolder\yourfolder\yourfolder to move to a specific folder within the drive you are currently in.

To display DOS 8.3 directory contents: Type dir /x /a

To rename a folder: Type ren currentfoldername newfoldername

Good Luck :D
Steve

#8 MrToad87

MrToad87

    Member

  • Full Member
  • Pip
  • 21 posts

Posted 12 May 2006 - 10:01 AM

I have this same problem, but it is a file, not a folder.

So I used the cmd dos method and have run into a problem. My file name has spaces in it, I'm not sure if this is the problem...

when I do the dir /x /a, I see the file ("HSHM Fac[1]. Meeting Oct.") and type ren HSHM Fac[1]. Meeting Oct. HSHMFA~1 and get the error "The syntax of the command is incorrect."

I'm guessing it's because of the spaces...any way to resolve this?

Thanks

[edit] was able to delete it with Unlocker anyways

Edited by MrToad87, 12 May 2006 - 10:04 AM.


#9 ScarBoro55

ScarBoro55

    Member

  • Full Member
  • Pip
  • 2 posts

Posted 12 May 2006 - 12:25 PM

when I do the dir /x /a, I see the file ("HSHM Fac[1]. Meeting Oct.") and type ren HSHM Fac[1]. Meeting Oct. HSHMFA~1 and get the error "The syntax of the command is incorrect."
I'm guessing it's because of the spaces...any way to resolve this?


The CMD editor was correct, the syntax was incorrect due to the spaces. :p What you should have seen in the editor was something similar to below when you typed the dir /x /a command:
(I created a file named the same as yours and added a txt extension).
05/12/2006 12:56 pm           128 HSHMFA~1.TXT HSHM Fac[1]. Meeting Oct.txt

See the item I highlighted in blue text? That's the correct file name to change. You used the long file name when you attempted to rename, whereas you should have used the HSHMFA~1.TXT short DOS 8.3 name. I believe I mentioned this as a CRITICAL step.

Your syntax should have been as follows:
ren HSHMFA~1.TXT HSHM.TXT

This would have probably resolved your issue, but I see you have already used a utility to get the job done. Glad to see it resolved in any case.

Peace...Out :D
Steve

Edited by ScarBoro55, 12 May 2006 - 12:28 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Member of ASAP and UNITE
Support SpywareInfo Forum - click the button