Jump to content


Photo

** EXPLORER.EXE 100% CPU AND MEMORY RISES ***


  • Please log in to reply
5 replies to this topic

#1 Firescanner

Firescanner

    Member

  • New Member
  • Pip
  • 1 posts

Posted 19 May 2004 - 12:13 PM

Hi,

I guess i'm the first to have a solution to this problem.

Problem i had was that when i got into a folder with a specific .avi file (++the_day_after_tommorow.avi) my system broke down, and had a explorer.exe running up to 100% cpu usage and memory leakage!

Now here is your solution..:))

open a dos-box
press control alt delete
in taskmanager close down explorer.exe
delete all NOT PLAYING avi files...
problem solved..

I guess there is a bug in explorer.exe and someone found out how to criple explorer.exe

Take care
eric

#2 wawadave

wawadave

    Advanced Member

  • Full Member
  • PipPipPip
  • 126 posts

Posted 19 May 2004 - 04:15 PM

sounds good!:)
<b>MYTH!!!!
Putting quotes around posts does not protect you from copy right infringement.</b>
<img src="http://img54.photobu...r_wawadave.gif" border="0" alt="IPB Image" />

#3 tennisjump

tennisjump

    Member

  • Full Member
  • Pip
  • 21 posts

Posted 19 May 2004 - 04:47 PM

what do you mean when you say open a dos box?

#4 lion7718

lion7718

    Advanced Member

  • Full Member
  • PipPipPip
  • 160 posts

Posted 19 May 2004 - 06:36 PM

This will fix it:

The obnoxious bug in XP that causes Explorer to read the entire contents of broken AVI files before allowing any access to them is caused by bad behavior of shmedia.dll.

This problem manifests itself by causing Explorer to read the entire contents of an AVI file, regarless of its size or location any time the mouse pointer is hovered over it, or an attempt is made to access it in windows explorer. This causes 'permission denied' errors when trying to simply move, copy or delete these files as they cannot be changed while Explorer has an open handle on them.

This also causes a DoS situation where large AVI's are stored on remote shares and Explorer keeps reading the files from beginning to end each time they are accessed.

To correct this misbehavior in Windows XP, remove the following registry key.

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32

This will prevent Explorer from loading shmedia.dll in response to file property queries on these files. This will not effect your ability to play files, get file attributes, or even view thumbnails. Say goodbye to all explorer.exe 100% CPU issues.

And Solution #2 (basically does the same thing, except you are inactivating the file attributes option)...But it WORKS--No more locked .avi files:

Well windows seem to have a REALLY big problem when it comes to reading AVI files. It seems that when you click on an AVI file in explorer, it'll try to read the entire AVI file to determine the width,height, etc. of the AVI file (this is displayed in the Properties window). Now the problem with Windows is that if you have a broken/not fully downloaded AVI file that doesnt contain this info, Windows will scan the entire AVI file trying to figure out all these properties which in the process will probably cause 100% CPU usage and heavy memory usage.

To solve this problem all you have to do is the following:

1. Open up regedit
2. Goto HKEY_CLASSES_ROOT\SystemFileAs
sociations\.avi\shellex\PropertyHandler
3. Delete the "Default" value which should be "{87D62D94-71B3-4b9a-9489-5FE6850DC73E}"

Please note that this will no longer provide you with the windows properties displaying the AVI file information such as width, height, bitrate etc. But its a small price to pay for saving you resources.

#5 milliecat

milliecat

    Member

  • New Member
  • Pip
  • 1 posts

Posted 03 January 2006 - 11:35 AM

Thank you so much.

This has been the source of a huge amount of irritation to me for a long time, and this is the only time someone's solution has actually worked!! As soon as I removed the registry key, the cpu dropped back down to normal levels and has been behaving well ever since.

Thanks again :lol:

#6 Tritoneangel

Tritoneangel

    Member

  • New Member
  • Pip
  • 1 posts

Posted 18 November 2006 - 11:09 AM

This will fix it:

The obnoxious bug in XP that causes Explorer to read the entire contents of broken AVI files before allowing any access to them is caused by bad behavior of shmedia.dll...

To correct this misbehavior in Windows XP, remove the following registry key.

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32

This will prevent Explorer from loading shmedia.dll in response to file property queries on these files. This will not effect your ability to play files, get file attributes, or even view thumbnails. Say goodbye to all explorer.exe 100% CPU issues...


You are officially the greatest person in the history of the universe. :thumbsup:


I have had that problem for the longest time, on more than one computer, and removing that registry key INSTANTLY fixed the problem. Thank you!

May the forces of evil become confused on the way to your house. :evilgrin:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Member of ASAP and UNITE
Support SpywareInfo Forum - click the button