Jump to content


Photo

internet connexion sharing + net function library


  • This topic is locked This topic is locked
17 replies to this topic

#1 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 08 October 2005 - 10:33 AM

Hi all,
don't know if this is the right place to post my pb...
i have 2 computers (XP pro) at home, one is connected to internet with adsl modem (ethernet connection). 2nd one is connected to the 1st one with ethernet cards (I use ICS to share my connection.) But since one week ( computer was one day without firewall, antivirus) I have no more access to internet from 2nd computer( file and printer sharing work fine). I checked all : network addresses, dns , firewall (fsecure internet security 2005) all seems fine.
So if someone have idea on it...

2nd pb : i have 2 services i can't remove : Net function Library(Handling all NET related functions for the local machine and Win 32 (Image Window for win32), i succeed to desactivate its, but there are still in my computer, (there where present in my hyjackthis log, but not possible to fix, but since i desactivated theses services they do not appear anymore in hijackthis log)

so dont know if my 2 pbs are related, but if someone have any idea, I would be very pleased.

ps : sorry for my poor english

and my log file seems ok (i said "seems" ^^ )

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Logfile of HijackThis v1.99.1
Scan saved at 18:10:20, on 08/10/2005
Platform: Windows XP SP1 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\SYSTEM32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\PROGRA~1\F-SECU~1\backweb\4476822\Program\SERVIC~1.EXE
C:\Program Files\F-Secure Internet Security\backweb\4476822\program\fsbwsys.exe
C:\WINDOWS\System32\nvsvc32.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Messenger Plus! 3\MsgPlus.exe
C:\WINDOWS\System32\rundll32.exe
C:\Program Files\Logitech\SetPoint\KEM.exe
C:\Program Files\SEC\Natural Color\NaturalColorLoad.exe
C:\Program Files\SEC\MagicTune 2.5\GammaTray.exe
C:\Program Files\Logitech\SetPoint\KHALMNPR.EXE
C:\Program Files\F-Secure Internet Security\backweb\4476822\Program\fspex.exe
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\Yahoo!\Messenger\ymsgr_tray.exe
C:\Program Files\F-Secure Internet Security\Common\FSMA32.EXE
C:\Program Files\F-Secure Internet Security\Common\FSMB32.EXE
C:\Program Files\F-Secure Internet Security\Common\FCH32.EXE
C:\Program Files\F-Secure Internet Security\Anti-Virus\fsgk32st.exe
C:\Program Files\F-Secure Internet Security\Anti-Virus\FSGK32.EXE
C:\Program Files\F-Secure Internet Security\Anti-Virus\fssm32.exe
C:\Program Files\F-Secure Internet Security\Common\FAMEH32.EXE
C:\Program Files\F-Secure Internet Security\FWES\Program\fsdfwd.exe
C:\Program Files\F-Secure Internet Security\FSPC\fspc.exe
C:\Program Files\F-Secure Internet Security\Anti-Virus\fsav32.exe
C:\Program Files\F-Secure Internet Security\Common\FSM32.EXE
C:\Program Files\F-Secure Internet Security\FSGUI\fsguiexe.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\F-Secure Internet Security\FSGUI\fsavgui.exe
C:\Program Files\Internet Explorer\IEXPLORE.EXE
C:\Program Files\F-Secure Internet Security\FSGUI\fsavaui.exe
C:\WINDOWS\system32\mmc.exe
C:\Program Files\Mozilla Firefox\firefox.exe
G:\download\Softwares\systeme\suppression de spyware\hijackThis\hijackthis1_99_1\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.yahoo.fr/
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens
O2 - BHO: Yahoo! Companion BHO - {02478D38-C3F9-4efb-9B51-7695ECA05670} - C:\PROGRA~1\YAHOO!\COMPAN~1\INSTALLS\cpn\ycomp5_3_18_0.dll
O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O3 - Toolbar: &Yahoo! Companion - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - C:\PROGRA~1\YAHOO!\COMPAN~1\INSTALLS\cpn\ycomp5_3_18_0.dll
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\System32\NvMcTray.dll,NvTaskbarInit
O4 - HKLM\..\Run: [MessengerPlus3] "C:\Program Files\Messenger Plus! 3\MsgPlus.exe"
O4 - HKLM\..\Run: [NeroCheck] C:\WINDOWS\system32\NeroCheck.exe
O4 - HKLM\..\Run: [F-Secure Manager] "C:\Program Files\F-Secure Internet Security\Common\FSM32.EXE" /splash
O4 - HKLM\..\Run: [F-Secure TNB] "C:\Program Files\F-Secure Internet Security\TNB\TNBUtil.exe" /CHECKALL /WAITFORSW
O4 - HKLM\..\Run: [F-Secure Startup Wizard] "C:\Program Files\F-Secure Internet Security\FSGUI\FSSW.EXE" /reboot
O4 - HKCU\..\Run: [Yahoo! Pager] C:\Program Files\Yahoo!\Messenger\ypager.exe -quiet
O4 - HKCU\..\Run: [SkwatAutoconnect] C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe
O4 - Global Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\KEM.exe
O4 - Global Startup: NaturalColorLoad.lnk = ?
O4 - Global Startup: Color Calibration.lnk = ?
O9 - Extra button: Filtre Web - {200DB664-75B5-47c0-8B45-A44ACCF73C00} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F01} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: Afficher la &liste des sites Web - {200DB664-75B5-47c0-8B45-A44ACCF73F01} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F02} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Interrompre le filtre de la page Web - {200DB664-75B5-47c0-8B45-A44ACCF73F02} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F03} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Refuser ce site Web - {200DB664-75B5-47c0-8B45-A44ACCF73F03} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F04} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Autoriser ce site Web - {200DB664-75B5-47c0-8B45-A44ACCF73F04} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O10 - Broken Internet access because of LSP provider 'winsflt.dll' missing
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://update.micros...b?1128206279360
O16 - DPF: {8EB3FF4E-86A1-4717-884D-7BA2D38272CB} (F-Secure Online Scanner) - http://www.securitoo...navol/fscax.cab
O16 - DPF: {A3009861-330C-4E10-822B-39D16EC8829D} (CRAVOnline Object) - http://www.ravantivi...n/ravonline.cab
O17 - HKLM\System\CCS\Services\Tcpip\..\{FF20A20D-A9D3-4A44-B421-FEDFEF148C69}: NameServer = 80.118.192.110 80.118.196.40
O23 - Service: ADSLAutoconnect - Unknown owner - C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe" -z (file missing)
O23 - Service: F-Secure Internet Security 2005 (BackWeb Plug-in - 4476822) - Unknown owner - C:\PROGRA~1\F-SECU~1\backweb\4476822\Program\SERVIC~1.EXE
O23 - Service: F-Secure Gatekeeper Handler Starter - F-Secure Corp. - C:\Program Files\F-Secure Internet Security\Anti-Virus\fsgk32st.exe
O23 - Service: fsbwsys - F-Secure Corp. - C:\Program Files\F-Secure Internet Security\backweb\4476822\program\fsbwsys.exe
O23 - Service: F-Secure Anti-Virus Firewall Daemon (FSDFWD) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\FWES\Program\fsdfwd.exe
O23 - Service: F-Secure HTTP Server (fshttps) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\FSPC\fshttps\fshttps.exe
O23 - Service: F-Secure Management Agent (FSMA) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\Common\FSMA32.EXE
O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\System32\nvsvc32.exe

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Edited by ethyx, 09 October 2005 - 03:08 AM.


#2 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 13 October 2005 - 08:37 AM

Hi ethyx,

Please download LSPFix from here.
Run the LSPFix.exe that you have just finished downloading.
Check the "I know what I'm doing" box.
In the Keep box you should see one or more instances of winsflt.dll. If you do not find any instances of it just click on the Finish button.
Select every instance of winsflt.dll and move each one to the Remove box by clicking the ">>" button.
When you are done click "Finish>>".

Reboot your computer and see if this resolves the connection problem.

#3 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 13 October 2005 - 02:10 PM

it didn't worked.
and after reboot, there was scanning and it took about 20 mn

It seems i have another pb: sometomes my computer doesn't stop, it stay at 'registering personal parameters" step

#4 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 13 October 2005 - 02:21 PM

Please post a new HijackThis log.

Also could you please explain what you mean by "registering personal parameters", this is not a normal Windows message.

#5 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 14 October 2005 - 11:26 AM

You will find my new HiJackThis log below (and you are right the operation you asked me to do removed this line "O10 - Broken Internet access because of LSP provider 'winsflt.dll' missing" from my Hijackthis log" but slave computer can't acces to the net)

...hmm and for the window message, it's normal message, I think it's my translation that is not normal... ^^
Maybe the good translation is "recording personal parameters" (the message comes just before the computer turned off)




Logfile of HijackThis v1.99.1
Scan saved at 19:14:28, on 14/10/2005
Platform: Windows XP SP1 (WinNT 5.01.2600)
MSIE: Internet Explorer v6.00 SP1 (6.00.2800.1106)

Running processes:
C:\WINDOWS\System32\smss.exe
C:\WINDOWS\SYSTEM32\winlogon.exe
C:\WINDOWS\system32\services.exe
C:\WINDOWS\system32\lsass.exe
C:\WINDOWS\system32\svchost.exe
C:\WINDOWS\System32\svchost.exe
C:\WINDOWS\system32\spoolsv.exe
C:\PROGRA~1\F-SECU~1\backweb\4476822\Program\SERVIC~1.EXE
C:\Program Files\F-Secure Internet Security\Anti-Virus\fsgk32st.exe
C:\Program Files\F-Secure Internet Security\backweb\4476822\program\fsbwsys.exe
C:\Program Files\F-Secure Internet Security\Anti-Virus\FSGK32.EXE
C:\Program Files\F-Secure Internet Security\Common\FSMA32.EXE
C:\WINDOWS\System32\nvsvc32.exe
C:\Program Files\F-Secure Internet Security\Anti-Virus\fssm32.exe
C:\Program Files\F-Secure Internet Security\Common\FSMB32.EXE
C:\WINDOWS\System32\svchost.exe
C:\Program Files\F-Secure Internet Security\Common\FCH32.EXE
C:\Program Files\F-Secure Internet Security\Common\FAMEH32.EXE
C:\Program Files\F-Secure Internet Security\FSPC\fspc.exe
C:\Program Files\F-Secure Internet Security\FWES\Program\fsdfwd.exe
C:\Program Files\F-Secure Internet Security\Anti-Virus\fsav32.exe
C:\WINDOWS\Explorer.EXE
C:\Program Files\Messenger Plus! 3\MsgPlus.exe
C:\WINDOWS\System32\rundll32.exe
C:\Program Files\F-Secure Internet Security\Common\FSM32.EXE
C:\Program Files\Yahoo!\Messenger\ypager.exe
C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe
C:\Program Files\F-Secure Internet Security\backweb\4476822\Program\fspex.exe
C:\Program Files\SEC\Natural Color\NaturalColorLoad.exe
C:\Program Files\SEC\MagicTune 2.5\GammaTray.exe
C:\Program Files\F-Secure Internet Security\FSGUI\fsguiexe.exe
C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe
C:\Program Files\MSN Messenger\msnmsgr.exe
C:\Program Files\Mozilla Firefox\firefox.exe
G:\download\Softwares\systeme\suppression de spyware\hijackThis\hijackthis1_99_1\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.yahoo.fr/
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Liens
O2 - BHO: Yahoo! Companion BHO - {02478D38-C3F9-4efb-9B51-7695ECA05670} - C:\PROGRA~1\YAHOO!\COMPAN~1\INSTALLS\cpn\ycomp5_3_18_0.dll
O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 7.0\ActiveX\AcroIEHelper.dll
O3 - Toolbar: &Radio - {8E718888-423F-11D2-876E-00A0C9082467} - C:\WINDOWS\System32\msdxm.ocx
O3 - Toolbar: &Yahoo! Companion - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - C:\PROGRA~1\YAHOO!\COMPAN~1\INSTALLS\cpn\ycomp5_3_18_0.dll
O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\System32\NvCpl.dll,NvStartup
O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\System32\NvMcTray.dll,NvTaskbarInit
O4 - HKLM\..\Run: [MessengerPlus3] "C:\Program Files\Messenger Plus! 3\MsgPlus.exe"
O4 - HKLM\..\Run: [NeroCheck] C:\WINDOWS\system32\NeroCheck.exe
O4 - HKLM\..\Run: [F-Secure Manager] "C:\Program Files\F-Secure Internet Security\Common\FSM32.EXE" /splash
O4 - HKLM\..\Run: [F-Secure TNB] "C:\Program Files\F-Secure Internet Security\TNB\TNBUtil.exe" /CHECKALL /WAITFORSW
O4 - HKLM\..\Run: [F-Secure Startup Wizard] "C:\Program Files\F-Secure Internet Security\FSGUI\FSSW.EXE" /reboot
O4 - HKCU\..\Run: [Yahoo! Pager] C:\Program Files\Yahoo!\Messenger\ypager.exe -quiet
O4 - HKCU\..\Run: [SkwatAutoconnect] C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe
O4 - Global Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\KEM.exe
O4 - Global Startup: NaturalColorLoad.lnk = ?
O4 - Global Startup: Color Calibration.lnk = ?
O9 - Extra button: Filtre Web - {200DB664-75B5-47c0-8B45-A44ACCF73C00} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F01} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: Afficher la &liste des sites Web - {200DB664-75B5-47c0-8B45-A44ACCF73F01} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F02} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Interrompre le filtre de la page Web - {200DB664-75B5-47c0-8B45-A44ACCF73F02} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F03} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Refuser ce site Web - {200DB664-75B5-47c0-8B45-A44ACCF73F03} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra button: (no name) - {200DB664-75B5-47c0-8B45-A44ACCF73F04} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O9 - Extra 'Tools' menuitem: &Autoriser ce site Web - {200DB664-75B5-47c0-8B45-A44ACCF73F04} - C:\Program Files\F-Secure Internet Security\FSPC\fspcmsie.dll
O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://update.micros...b?1128206279360
O16 - DPF: {8EB3FF4E-86A1-4717-884D-7BA2D38272CB} (F-Secure Online Scanner) - http://www.securitoo...navol/fscax.cab
O16 - DPF: {A3009861-330C-4E10-822B-39D16EC8829D} (CRAVOnline Object) - http://www.ravantivi...n/ravonline.cab
O17 - HKLM\System\CCS\Services\Tcpip\..\{FF20A20D-A9D3-4A44-B421-FEDFEF148C69}: NameServer = 80.118.196.40 80.118.192.110
O23 - Service: ADSLAutoconnect - Unknown owner - C:\Program Files\ADSL Autoconnect\ADSL Autoconnect.exe" -z (file missing)
O23 - Service: F-Secure Internet Security 2005 (BackWeb Plug-in - 4476822) - Unknown owner - C:\PROGRA~1\F-SECU~1\backweb\4476822\Program\SERVIC~1.EXE
O23 - Service: F-Secure Gatekeeper Handler Starter - F-Secure Corp. - C:\Program Files\F-Secure Internet Security\Anti-Virus\fsgk32st.exe
O23 - Service: fsbwsys - F-Secure Corp. - C:\Program Files\F-Secure Internet Security\backweb\4476822\program\fsbwsys.exe
O23 - Service: F-Secure Anti-Virus Firewall Daemon (FSDFWD) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\FWES\Program\fsdfwd.exe
O23 - Service: F-Secure HTTP Server (fshttps) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\FSPC\fshttps\fshttps.exe
O23 - Service: F-Secure Management Agent (FSMA) - F-Secure Corporation - C:\Program Files\F-Secure Internet Security\Common\FSMA32.EXE
O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\System32\nvsvc32.exe

#6 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 14 October 2005 - 12:54 PM

Hi ethyx,

Your HijackThis log looks fine.

The first thing that you need to do is update Windows to Service Pack 2, you can do this by going to the Windows Update site, just open IE, click on Tools, Windows Update then download and install SP2 and any additional critical updates.

Now on your slave computer (the one that cannot access the internet) click on Start, Run, type in cmd and press enter.

In the Command window that opens type in ipconfig /all and press enter. Check to see what IP address has been obtained, it should be a 192.168.0.x address. If it is any other IP address check your TCP/IP settings to make sure you are obtaining an IP address automatically.

Let me know what you find on the IP address.

#7 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 14 October 2005 - 01:15 PM

on slave computer i already g manually configured the adress : 192.168.0.2 (it do not works when i try to give an ip automatically).
gateway : 192.168.0.1 (master computer)
dns :192.168.0.1

I can't run sp2 on my computer , cause it slow down to much all aplications on it. I tried once, and after few days decided to reinstall xp. i will wait to get a more powerfull computer to update to SP2

#8 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 14 October 2005 - 01:23 PM

Ok, on the slave computer can you ping the master computer (192.168.0.1)? Can you ping an external url such as www.yahoo.com?

#9 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 14 October 2005 - 01:41 PM

o i can ping 192.168.0.1, local network works fine, i can access file frome one to other computer without pb, on both sides
i can't ping any external adress

#10 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 14 October 2005 - 01:50 PM

Are you running a firewall on the master computer?

#11 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 14 October 2005 - 03:59 PM

yes, f'secure internet security 2005, but it worked fine with it before i had theses troubles ...
and i tried to remove it, and it didn't changed anything

#12 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 14 October 2005 - 08:06 PM

Hi ethyx,

If you cannot obtain an IP address from the master computer when the slave is set to obtain one automatically then Internet Connection Sharing is not properly setup.

Go to this website and carefully follow the instructions for setting up ICS on XP:

http://www.practical...sharing/xp_ics/

#13 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 14 October 2005 - 08:57 PM

Already tried this more than once, with wizzard or manually, same results : it does not work.
I tried again tonight using wizzard, but still not working and client computer seems to not be able to get a dhcp adress

#14 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 15 October 2005 - 06:37 AM

ok you will find below an ipconfig /all on master computer :

slave computer can ping this adress 84.97.51.62 (modem adress i suppose) but can't go further




Configuration IP de Windows

Nom de l'hôte . . . . . . . . . . : TINE-D98D6ANAFY
Suffixe DNS principal . . . . . . :
Type de noud . . . . . . . . . . : Inconnu
Routage IP activé . . . . . . . . : Non
Proxy WINS activé . . . . . . . . : Non

Carte Ethernet Connexion Bene:

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Carte réseau Fast Ethernet PCI Real
ek RTL8139 Family
Adresse physique . . . . . . . . .: 00-48-54-D0-4F-CC
DHCP activé. . . . . . . . . . . : Non
Adresse IP. . . . . . . . . . . . : 192.168.0.1
Masque de sous-réseau . . . . . . : 255.255.255.0
Passerelle par défaut . . . . . . :

Carte Ethernet Vers internet:

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Carte réseau Fast Ethernet PCI Real
ek RTL8139 Family #2
Adresse physique . . . . . . . . .: 00-10-A7-0F-0B-D2
DHCP activé. . . . . . . . . . . : Oui
Configuration automatique activée . . . . : Oui
Autoconfiguration d'adresse IP. . : 169.254.157.137
Masque de sous-réseau . . . . . . : 255.255.0.0
Passerelle par défaut . . . . . . :

Carte PPP NeufTelecom :

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Adresse physique . . . . . . . . .: 00-53-45-00-00-00
DHCP activé. . . . . . . . . . . : Non
Adresse IP. . . . . . . . . . . . : 84.97.51.62
Masque de sous-réseau . . . . . . : 255.255.255.255
Passerelle par défaut . . . . . . : 84.97.51.62
Serveurs DNS . . . . . . . . . . : 80.118.192.110
80.118.196.40
NetBIOS sur TCPIP. . . . . . . . : Désactivé

#15 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 15 October 2005 - 12:52 PM

Hi ethyx,

Try disabling this network connection on the master computer:

Carte Ethernet Vers internet:

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Carte réseau Fast Ethernet PCI Real
ek RTL8139 Family #2
Adresse physique . . . . . . . . .: 00-10-A7-0F-0B-D2
DHCP activé. . . . . . . . . . . : Oui
Configuration automatique activée . . . . : Oui
Autoconfiguration d'adresse IP. . : 169.254.157.137
Masque de sous-réseau . . . . . . : 255.255.0.0
Passerelle par défaut . . . . . . :



#16 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 15 October 2005 - 02:18 PM

did it, but it close immediatly the connection to internet on master computer, as this is the ethernet card conencted to the adsl modem

#17 jw50

jw50

    Forum Deity

  • Retired Staff
  • PipPipPipPipPip
  • 18,969 posts

Posted 15 October 2005 - 03:15 PM

Hi ethyx,

Ok, enable that one again.

The problem is that adapter is being autoassigned a dummy IP address by Windows.

The best thing for you to do is call your ISP technical support, they will be able to help you resolve this problem alot easier than I will be able to.

#18 ethyx

ethyx

    Member

  • Full Member
  • Pip
  • 20 posts

Posted 16 October 2005 - 04:13 AM

ok thks for help i will try with my provider... not sure they will answer as fast as you .. ^^




Member of UNITE
Support SpywareInfo Forum - click the button